SharePoint Config Database gone Suspect Mode..

I had my SQL and SharePoint in VM Nodes. just while a go realized that SharePoint Config DB suddenly gone suspect after restarting my host which was unexpected.

image

Option 1.

The very first option came to my mind is to restore the database through a previous backup but I didn’t had a one since this is a new farm.

Option 2.

luckily there was an another option which is just an query as simple as below.

— Use the Master database
Use Master

— Verify that database has issues
EXEC sp_resetstatus ‘SharePoint_Config’

— Put the database in emergency mode
ALTER DATABASE SharePoint_Config SET EMERGENCY
DBCC checkdb(‘SharePoint_Config’)

— Set the database in single user mode
ALTER DATABASE SharePoint_Config SET SINGLE_USER WITH ROLLBACK IMMEDIATE

— Repair the database with data loss
DBCC CheckDB (‘SharePoint_Config’, REPAIR_ALLOW_DATA_LOSS)

— Set the database in multi-user mode
ALTER DATABASE SharePoint_Config SET MULTI_USER

— Verify that database is reset
EXEC sp_resetstatus ‘SharePoint_Config’

after running this the issue was fixed and I was able to get in to the Central Administration and other Web applications

image

Note: This can happen on any SQL DB and as per most of the blogs on web, SharePoint DB get corrupted occasionally when VM s restarts unexpectedly

so make sure that you save your VM before restart your host though it’s on staging or development because recovering takes time so better to avoid it without wasting.

Latest Cumulative Update February 2013 has been Released for SharePoint 2010

So it’s another update to consider about to have on your SP farm. As per my knowledge, this is the 20th CU release for SharePoint 2010. Massive number of releases isn’t it !

Download the package here – http://support.microsoft.com/kb/2767793

To install this hotfix, you must have SharePoint Server 2010 Service Pack 1 or SharePoint Foundation 2010 Service Pack 1 installed.

Note: Do not apply directly in to production without testing on Staging.

This Update Fixes Below Issues

  • When you remove a hyperlink from a Hyperlink with formatting constraints for publishing column in SharePoint Server 2010, new hyperlinks cannot be added to the column.
  • Assume that you have a document library named “Transfer” that has been recently accessed in SharePoint Server 2010. You run the Merge-SPLogFile cmdlet to return Unified Logging Service (ULS) log entries by using a correlation ID filter. In this situation, the cmdlet returns no results and you receive the following error message:
    WARNING: Cmdlet did not return any records in the log file. Check your time range or filters.

This cumulative update package also fixes the issues that are described in the following Microsoft Knowledge Base (KB) articles:

  • 2760774
    Description of the SharePoint Foundation 2010 hotfix package (Wss-x-none.msp): February 12, 2013
  • 2767795
    Description of the SharePoint Server 2010 hotfix package (Coreserver-x-none.msp): February 12, 2013
  • 2589344
    Description of the PerformancePoint Services for SharePoint Server 2010 hotfix package (Ppsmawfe-x-none.msp): February 12, 2013

Error when creating a New Item in SharePoint “An Unhandled Exception Occurred in Silverlight Application”

Huh .. Just got my new test lab of SP 2010 created and it gives an error saying that “An Unhandled Exception Occurred in Silverlight Application” when I’m trying to create an new item (Library/List or any other new item).

image

was looking for other’s on web and realized that it’s a common thing. done below steps and restarted IIS, error was gone !

1. Go to Central Admin –> Application Management –> select your web application –> General Settings of particular web Application

image

2. Direct to Web Page Security Section and switch on the Security Validation if it’s off. sometimes you may turn it off and then turn on if it’s already on then it would work.

image

that’s all. give a try now with a new browser tab, you wont see the error now. if the problem persist – Restart the IIS of all SP Servers and try again.